Self signed certificate error when setting MS SQL Server connection

Hi, I am new for n8n. I got a “failed to connect to servername:1433 - self signed certificate” error when setting the MS SQL Server connection account.

Does anyone has any ideas?

  • Running n8n via npm

@anderson.wong

Try to set

NODE_TLS_REJECT_UNAUTHORIZED: 0

to docker env file

1 Like

I am using the npm (Windows platform). Where is the env file to set this parameter?

Hey @anderson.wong,

You would need to set it before running the start command although the export option would possibly work on Windows as well.

You might want to check out Microsoft’s docs for PowerShell on environment variables: about Environment Variables - PowerShell | Microsoft Learn

The tl;dr would be $Env:VARIABLE_NAME = 'Variable Value'

1 Like

I tried the following:
SET NODE_TLS_REJECT_UNAUTHORIZED=0
n8n start

but still cannot connect to SQL Server, same error:

In this case support for self-signed/untrusted certificate might be a new feature that we’ll need to implement I am afraid. I’ll convert this question into a feature request for now so you and other users interested in this can vote on it @anderson.wong

1 Like