Spreadsheet node not working anymore

Hi,

I have a workflow that has been running for a long time now. It has always worked fine but last week it suddenly stopped working. I found what’s wrong but I don’t understand why and I guess it’s a bug in N8N…
I use the spreadsheet node to read a csv file. This always worked fine like this screenshot from 3rd of June:


But suddenly the next day something strange happens with the data:

Can anyone help please because this issue is very urgent. I know there is a new node to read a file from csv to json but this also does not work because something goes wrong when the values of the csv are in quotes:

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

I use n8n cloud with version 1.42.1

Hi @Marciano_Antonacci

I think this should work when you set the option to Exclude BOM

1 Like

Hi Ria,
You’re correct! I received another error because the delimiter was “;” instead of “,”… But after setting the delimiter option it worked perfectly fine.
Thanks a lot

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.