Spreadsheet node not returning data

!-- Hey! To help you find a solution faster, please follow the template below. Skip the questions that are not relevant to you. →

Describe the problem/error/question

I have a Spreadsheet File node followed by a Read Binary node. However, I’m encountering a problem where the spreadsheet file is not retrieving any data from the Read binary node.

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Akbar_husain,

Welcome to the community :raised_hands:

Rather than autodetect can you try setting it to can to see if that helps? If your file is not using a standard , to separate files you may need to add that as an option as well.

You are also on an older version so it could be that the ( ) in the node name is causing an issue so I would also try removing those or update n8n.

hey @Jon I had set file format to xlsx and removed () from the node name but still not working.

just see the type of file in below image


Screenshot 2024-02-16 204647

Hey @Akbar_husain,

Can you share the file? or have you tried it with another file?

sorry! I can’t

I have tried with different files, but the same problem keeps occurring. Every time I open the file and save it before executing the workflow, after that workflow works perfectly

any solution regarding this ?

Hey @Akbar_husain,

Sadly to have a solution we will need to find a way to reproduce it, Can you try the workflow below that downloads a random CSV file and let me know if that works.

When you also say that you need to open the file and save it the workflow then works what do you actually mean there? I am wondering if maybe the file is the issue or the way it is being created / loaded.

This Error occurs only when the file format is XLSX.
Above worklow is working perfectly.

When I download the file from the portal and try to use it through the workflow, it doesn’t work; it gives an error. However, after I open the file and save it without making changes, the workflow works perfectly
so, my question is why workflow is not working at first time?

Hey @Akbar_husain,

I went for a CSV as your first post shows a CSV with the same issue, The workflow at the bottom is using an xlsx file can you also test that one.

I don’t know why it is failing on the first run but if you are doing something outside of n8n to get it working in n8n then it would suggest the issue is something with the file itself.

Hey @Akbar_husain,

It sounds like there is potentially something different with your file, Are you able to make a file with mock data that has the same issue so we can investigate further?

hey @Jon

I had solved this problem with some other way.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.