SQL node not working since upgrading to the latest n8n version

We have been running n8n for months and we’ve got a workflow that inserts into an MS SQL table. It has worked flawlessly however yesterday I decided to update n8n and now it is no longer working as it can’t find the table.

Any ideas? Has there been a breaking change somehow?

Job history, no prizes for guessing when I updated:

Flow showing issue:



Flow prior to upgrade:


Current updated version: 1.24.1
Previous version: unknown, it was from around October if memory serves me correct.

Using Docker.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

To confirm, it is still connecting fine to the SQL DB:

I’ve just found the issue. As soon as I added brackets around my tables, it is working fine.

so IMPORTS.TEMPDATA became [IMPORTS].[TEMPDATA] and now it works. Keeping here in case anyone else has this issue.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.