Microsoft SQL Node throwing error after upgrade


I upgraded from 0.193.3 to 0.193.5 last night and this morning I ran a workflow that uses a Microsoft SQL node and it is failing on the SQL node. It gives the error:

TypeError: Cannot read properties of undefined (reading 'json')
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/NodeExecuteFunctions.js:851:18
    at Array.forEach (<anonymous>)
    at Object.returnJsonArray (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/NodeExecuteFunctions.js:850:14)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Microsoft/Sql/MicrosoftSql.node.js:311:84)
    at async Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/src/Workflow.js:598:28)
    at async /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/WorkflowExecute.js:557:53

I tried setting up workflow with just a start node and the SQL node to see if the issue was somewhere else in my workflow but I get the same error. Here is the workflow:

System Information

  • 0.193.5
  • Database I’m using SQLite
  • Running n8n via Docker

This workflow was running without errors in 0.193.3. I’m not sure if there is a way I can adjust the node to make it work or if I need to try to downgrade. I’d appreciate any help and advice.


Hi @krima, I am sorry to hear you’re having trouble. Can you try upgrading to n8n version 0.194.0? This would include a fix for operations not returning any rows, such as DROP TABLE like in your workflow.

Upgrading has fixed the issue. Thanks for the fast response!