Webhook "Ignore bots" toggle

Hi all,

Sharing a lesson that costed me one hour, in case someone has the same issue.

Issue: I kept receiving “Authorization data is wrong!” on my webhook, despite having not set any authentication on the webhook node.

I tried several combinations of curl parameters in vain.

The root cause was that I had activated the toggle “Ignore bots” on the webhook node when setting it up. I didn’t think that I would then later call my webhook from a bot of mine.

Lesson: the “Ignore bots” toggle works well and returns “Authorization data is wrong!” when a bot makes a call to the webhook

Suggestion: There’s no mention of the “Ignore Bots” on Webhook - n8n Documentation or anywhere within n8n documentation, would it be worth adding it?

Hey @jb8n,

Welcome to the community :tada:

Thanks for pointing this one out, I have put in a quick line to the docs about the setting that will be available once it has been reviewed and merged.

1 Like