Why n8n asking to enter a value in ID field when using PostgreSQL Node?

Describe the problem/error/question

I have created a table in PostgreSQL using the following:

create table
  public.austin_api_logger (
    id bigint generated by default as identity,
    created_at timestamp with time zone null default now(),
    status_code integer null,
    count_num_of_rows integer null,
    last_offset bigint null,
    execute_date_time timestamp with time zone null default now(),
    constraint austin_api_logger_pkey primary key (id)
  ) tablespace pg_default;

Here the id field is auto increment. But when I try to insert record in PostgreSQL using Postgres node by setting Mapping Column Mode to Map Each Column Manually it asks me enter a value in the id field.


What is the error message (if any)?


Information on your n8n setup

  • n8n version: 1.0.5
  • Database (default: SQLite): PostgreSQL

Hey @YogiYang,

When using the auto mapping while we know there is a field and what the data type is we don’t check to see if it is auto generated at the moment. The work around for this is to use the execute query option and input the query you want to run there.

1 Like



This worked for me.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.