Wordpress Credential Fail

Describe the problem/error/question

My n8n has problems with Wordpress credentials, I use the latest version of Wordpress 6.2.2, when trying to use a filter from the N8N node where I need to retrieve private posts, I get an error in the image below:

My credentials when testing are correct, however if I type anything in the username and password it shows that it is authenticated, this looks weird.

Please share your workflow

image

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • **n8n version:0.231.3
  • Database (PostgreSQL):
  • n8n EXECUTIONS_PROCESS setting (Queue):
  • Running n8n via (Docker):
  • **Operating system:Debian 11

Hey @vinicius_dtnetwork

Welcome to the n8n community :tada:

Are you using your WordPress backend login password or an application password as described in the node documentation?

I have reproduced your workflow query and in my case it works without problems.

:wink:

Hey @vinicius_dtnetwork,

Welcome to the community :raised_hands:

The Wordpress API can be used without authentication in some configurations, I will get the credential test updated to use an endpoint that requires valid credentials.

It sounds like @martinhache is on the right lines and you were not using an application password.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.