[172.0] Nodes position not saved

Describe the issue/error/question

I’m moving nodes around, trying to make my flow look linear but every time I load it it’s messy again. I think that node position is not updated. I’ve tried making some change to node (add/delete) and save flow but after reload nodes are in ‘random’ positions. It’s not random, because it’s the same every time, but not what I saved.

Please share the workflow

Information on your n8n setup

  • n8n version:0.172.0
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]:npm

Hello, are you by any chance using tablet or touch screen? Because that’s a known issue for those platforms. I did a quick test on latest Chrome, Firefox and Safari and I cannot reproduce. Which browser and what version of that are you using so I can try to reproduce? Did you not experience this in previous versions?

I’m using laptop with a touch screen, but I don’t use it to set up a workflow. Instead I use mouse.
I think that there was no issue on previous version (170).

Brave: 1.37.113 Chromium: 100.0.4896.88 (Official Build) (64-bit)
Edge: 100.0.1185.36 (64-bit)
Firefox: 99.0.1 (64-bit)

Tested on laptop without touch screen. Works correctly.
Brave 1.37.113 Chromium: 100.0.4896.88 (Official Build) (64-bit)

1 Like

Touchscreen related then. Related Github issue is here Nodes all mixed up under iPadOS within Editor UI · Issue #1989 · n8n-io/n8n · GitHub

1 Like

Can confirm same issue with [email protected] and Lenovo laptop with touchscreen.

1 Like

Same issue on HP laptop with touch screen. [email protected]
Impossible to work with.

Just to add, I use an external monitor and mouse. But my laptop has touch screen.

Found a work-around untill the issue is fixed.
Disable touchscreen Microsoft - Disable touch screen, reboot and done.

1 Like

Hey @Rugia,

Welcome to the community :raised_hands:

It looks like it could be a known issue with touch devices, That fix is handy to know about.

Fix got released with [email protected]

1 Like

I confirm, that I’m no longer seeing this issue. Great work! :smiley:

I tried building some workflows the other day on my brand new and up-to-date iPad Air, and I’m running into exactly the same issue. Both in Safari and Chrome.

Hey @dickhoning,

I noticed the reply on the GitHub issue :raised_hands:

Unrelated to this issue… What is the Air like I am thinking about getting one to replace. my old mini.

@Jon I love it! Together with the magic keyboard it’s basically a tiny laptop with touchscreen. I used it on a long (10 hour) flight the other day, did some work, watched a movie, and still got plenty of battery left😎

1 Like

Deal! I will order one now. Thanks buddy