(BUG): Executions not working fine, when I try to see one execution it displays another one

Describe the issue/error/question

Since the new executions update, I can’t easily access the executions history or do quick searches…
If I try to see a 2 hours ago log when I press the button to see the execution, it doesn’t target the right execution.

What is the error message (if any)?

I have recorded a video, but it contains sensitive data. I can send the video by PM to any mod or admin.

Information on your n8n setup

  • n8n version: 0.205.0
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: docker

Hi @yukyo, I am so sorry for the trouble.

I am not sure I quite understand what’s happening. Is there any chance you can create a reproducible example not containing without any confidential data and confirm the exact steps required to reproduce the problem?


I’ve a similar issue when I try to load from the URL a specific execution ID.

For exemple I go go the workflow ID 10, and click on executions tabs, first it loads the last execution that ok.

But then I change the URL with my execution ID (that I found in database, with specific data) and it’s still load the last execution (refresh page). So I need to scroll down to find my execution ID but sometime it’s impossible because we have too many executions so to find the good one take too much time.

I use v 201.0 I have to test with new version if it’s still the same

This issue comes only with Firefox, when I change the URL in chrome with the specific ID of the execution that I want, ti works.

Before the redirect, in firefox we have the following message :

Hi @Kent1, thanks so much for sharing these additional details. I’ve just tried reproducing this problem using a more recent version of n8n (0.206.1) and the current Firefox version, but navigating to an execution ID by changing the URL seems to work fine for me:

Recording 2022-12-15 at 12.06.09

Perhaps you can give this another go after upgrading n8n?

Hi @MutedJam,

Thanks a lot for your reply.

I will update n8n today I will let you know if I still have the issue.

1 Like

Hi @MutedJam,

I’ve update to n8n 0.208.0 but I still have the same issue


I’ve record the issue if you want I can send you the video in private.

Thanks @Kent1, with your video and a similar report on Discord I was able to reproduce the problem. I’ve added this to our engineering backlog for a fix and we’ll confirm once this has been released.

Hey, @Kent1
I think we nailed down what’s causing the issue you (and some others) reported and the fix should be available on 0.208.1 version of n8n.
Can you try updating and let us know if the issue is still here.

Hi @milorad milorad,

I’ve update to 0.208.1 but I still have the same issue.

@Kent1 thanks for getting back so quickly. Spoke in the meantime with @MutedJam and he also confirmed that the issue is still here, so back to the drawing board I guess.
Will follow up with updates on this.

Hi @milorad and @MutedJam. Not sure if the same issue that @MutedJam found in his testing, but I’m submitting this video that I recorded some days ago about the issue, which is why I opened this OP thread.

It is really hard to track and see an execution when n8n runs in mass-executions projects like mine.

You have to really struggle and waste up to 20 minutes to be able to see some executions.

This is the video:

I hope this helps to understand the problem.

@yukyo thanks much for the video an the explanation. It’s strange that executions list in the new tab is not loading more executions when you scroll to the bottom, haven’t seen that one reported yet. Anyway will be spending more time on this and will follow up here.
Can you just confirm which version of n8n are you using in the video?

@milorad I was using the 0.205.0 version in the video, but I can tell you I’m using 0.207.1 now and still have the same issue. I can’t see a specific execution, and the left menu shows some recent executions, but it doesn’t scroll down…


@yukyo Thanks.
We released a fix for wrong execution display i the 0.207.1 version. Even though it looks like it doesn’t fix all issues, is there a chance for you to try updating to 0.207.1 and letting us know how it went?

@milorad I’m already running 0.207.1, as said in my previous message, with no changes. It still shows the wrong execution when I press the folder icon, and the execution ID doesn’t show the proper execution.

What I have found as a bug is if I stay on the execution page with a random execution open for 20-30 minutes as new executions get added, at some point, the scroll down starts to become bigger and bigger. If I waited for enough (I waited for almost 1 hour), I reached the execution that I wanted to inspect… odd and very slow to check executions quickly in case of emergency…

I think there is a mixup. The fix @milorad is referring to got released with version 0.208.1.

Here is the PR


I have the same issue with the loading of execution when I scroll down there is no other execution. it’s limited and then I have to go to execution tab to load older one

@milorad I am confused, I was under the impression that the new executions tab simply just always displays the last 20 executions and that is it. So sounds to me like expected behavior. You are saying it is supposed to automatically load more?!?!

@Kent1 The only thing the above PR fixes is that it does display now the correct information in the top left side of the workflow execution. That part:
Screenshot from 2022-12-20 18-08-06
The rest of the execution was always displayed correctly as far as I understand.

And what’s the benefit of having the new executions tab that only displays the last 20 entries if I have to keep using the main one every time I need to get an execution?

However, as said, if I keep the page open for enough time, the scroll becomes bigger… so not sure what is the exact right behavior of the new exeuctions list…

But it’s not enough, the experience with the executions isn’t good enough. If you have to search for execution 2 hours old or more, it’s just a pain to reach it. You have to waste 10 minutes pressing the “Load more” button, and once you arrive at the execution, you press the folder icon to see it, and it loads the last execution :man_facepalming:

Also when you scroll down for a while in the main executions I can’t open multiple executions with right click, I have to scroll down again :skull_and_crossbones: