Execute workflow didn`t work with new workflow id

Hello!
When i add another “execute workflow” node to the old workflow, it returns error “resource you are requesting could not be found”.
I use new workflows id (vXsEVPwyloCFbhk3) in the node “execute task-list”
Old execute workflow nodes with old id`s works fine.

n8n version: 236.3
Database: SQLite
Running n8n via Docker

My workflow:

Hi @coldnaked :wave:

I know this sounds like a very stereotypical question, but can you double-check your workflow ID for typos? :see_no_evil:

I just tried this out and even copying an old node that had the numerical ID, I couldn’t get an older workflow with that ID structure to fail when using the newer workflow nano ID structure, too. No matter what, I could mix and match (which was my initial thought as to what the problem was).

It’s worth noting that I also tried this on a newer (1.3.1) version of n8n. If double-checking your IDs doesn’t work, can you try updating and seeing if that sorts this out?

And if that still doesn’t work, I’d need some further details on how to reproduce this one :bowing_man:

2 Likes

Solved.
I did a remake for the old entrance workflow and executed workflow.
Looks like it was incompatibility between old “entrance” and new “executed” scenario (with new id`s).

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.