Execute Workflow Node and Workaround

Describe the problem/error/question

I got this error when trying to use Execute Workflow to run other workflows, my current plan is FREE, and looks like it can’t use this node, I wanna know if we have another solution for this?
I’m just having an idea about Webhook Node (Resources for this gonna very high if I have 4-5 workflows are listening on the same time)

{
  "errorMessage": "The service was not able to process your request",
  "errorDetails": {},
  "n8nDetails": {
    "nodeName": "HTTP Request",
    "nodeType": "n8n-nodes-base.httpRequest",
    "nodeVersion": 4.1,
    "time": "3/27/2024, 11:48:30 AM",
    "n8nVersion": "1.33.1 (Self Hosted)",
    "binaryDataMode": "default",
    "stackTrace": [
      "NodeApiError: The service was not able to process your request",
      "    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/HttpRequest/V3/HttpRequestV3.node.js:1571:35)",
      "    at processTicksAndRejections (node:internal/process/task_queues:95:5)",
      "    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:724:19)",
      "    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:660:53",
      "    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:1062:20"
    ]
  }
}

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

DB_TYPE: Postgres
Operating System: Ubuntu 22.04

The node is available for free, so in every plan. Sounds more like something is going wrong in a HTTP Request node in the sub workflow. So I would open that specific sub workflow execution and check out what is going on.

Many thank Jan, looking forward to getting the solution on this.
FYI: I’m using this docker-compose
I just modified the DB environment to DB_POSTGRESDB_USER=${POSTGRES_USER}, running on local and protocol is http

Wait, The error is about the HTTP Request Node, it has nothing in common with the Execute Workflow node :thinking:

Can you share the workflow(s)?

1 Like

Ow, thank for pointing it out. I made a mistake. I thought it was about the main-workflow not sub-workflow.
Thank you very much!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.