gSheet Trigger brings all rows on update instead of updated rows

Hey,

I update only some rows on Google Sheets but it returns all rows everytime. I activated the flow, tried to create a new flow and a new google sheet module.

Information on your n8n setup

  • n8n version: Version 1.1.1
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker):
  • Operating system: Linux Ubuntu 22.04 X64

any ideas?

sorry, kind of urgent

I think there are some solid problems about google sheet trigger node. I keep trying things options part as well but it doesn’t work. Or I am wrong.

Hi @onurbolaca :wave:

I had a quick test here, and after my first execution, which returns all rows:

Any subsequent updates only show the new rows edited:

What you’re seeing however is expected if you just press the Execute Workflow button as we don’t read the internal static data to work out what the last row read was - have you been testing manual executions?

1 Like

Hey @EmeraldHerald ,

Thanks for your answer,

I read the forum and saw this answer before. So that’s why I spesically tried when the flow is active. I kept trying by triggering the sheet trigger, it was the same result on each one as it can be seen on the screenshots.

My version is as is it written and I use community version of n8n.

I’m not able to replicate this, @onurbolaca :thinking: Can you provide an example sheet that we can make a copy of to use for testing that wouldn’t have any sensitive data, and an example workflow that you’re using so we can test this?

For the workflow, if you hit ctrl/cmd + a and then ctrl/cmd + c whilst in the workflow editor, you can then paste that over here on the forums between two sets of three backticks (```) to share the workflow :slight_smile:

1 Like

Thats weird because I tried in two different versions on two different linux servers. I will share my flow as soon as I can.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.