HubSpot Trigger Node broken Authentication Provider

Describe the problem/error/question

It appears that HubSpot has (sometime in the past) switched to a new authentication scheme. There are relevant topics that I’ve read over that haven’t solved this problem. (Hubspot Trigger and Authentication and Hubspot Triggers Authentication)

I’ve followed the n8n documentation exactly (HubSpot credentials | n8n Docs) but still no success.

This is all made much harder because I’m a contractor with limited credential access to the actual hubspot accounts. I have access to admin permissions, but not on demand, which has made debugging trickier.

As a result, this is costing us all our executions since we’re having to poll hubspot very freqently for changes.

Help?

What is the error message (if any)?

Bad authentication error from Hubspot.

Please share your workflow

It’s just the hubspot trigger node, listening for contact created.

Information on your n8n setup

  • n8n version: Latest Stable Cloud
  • Database (default: SQLite): Whatever Cloud is using
  • n8n EXECUTIONS_PROCESS setting (default: own, main): Cloud default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Cloud

And now I’ve got it working! No errors on n8n’s part, although I would request a clarification in the docs:

In “Using OAuth”, step number 8, I would recommend explicitly stating that if you’re using the trigger node, you should have those scopes and ONLY those scopes, and if you’re using a regular node, you need the other scopes. We saw the warning below the scopes about using exact scopes, but we didn’t realize that you couldn’t just use one set of credentials for both the trigger and the regular nodes, and add all of both scopes to the authentication. I would make that clearer.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.