Known hosts of ssh2

Describe the problem/error/question

I would like to connect to a Linux device with SSH which I had to reset. Currently, the authentication does fail, probably because of the changed host key. On other PCs I have to remove an entry within the known_hosts file but I’m not able to find that one within the /home/node/.n8n folder.

Does somebody know where those keys are stored? They have to be within /home/node/.n8n because that’s my only Docker volume and I deleted the container multiple times.

What is the error message (if any)?

All configured authentication methods failed

Please share your workflow

Not relevant.

Share the output returned by the last node

See error message.

Information on your n8n setup

  • n8n version: 0.217.2
  • Database (default: SQLite): Sqlite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu 22.04

Hey @ericfischereu,

You shouldn’t have to worry about known hosts with n8n, How are you authenticating is it with user / pass or with a key?

Thanks for the fast reply. I’m using key auth.

When you reset the Linux device did you add the public key back that n8n would be using or update n8n to use a new private key?

I’m using the same private key I’m using in some other tools, where it works.

However, I made a rebuild (using a custom image with curl, pythons and ja and the node modules node-ical, scrapegoat, UUID and tsdav) and updated to 0.227.0-debian. Now it works with exactly the same credentials.

I’m a little bit embarrassed that I haven’t tried that earlier…

Should I test this for a potential bug or is this issue resolved for you?

1 Like

I am happy it is resolved, I did change the public key of an SSH server I have to force the same issue but it seemed to work for me.

I can do some more digging in the background the important thing is you are up and running.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.