Mailchimp trigger not activating

Hi guys,

I’ve registered an API key to my Mailchimp and am trying to get the data of new subscribers, updates, etc. The picture below shows my node:

When I try to activate it I get the error message below:


This is recent as before I could activate it but I just never got any data (I tried changing the list and nothing).

Also, I tried inserting the webhook test link in the browser and it did not find anything (so might be an issue with the webhook?).

Hi @Daniel_Barra,

Did you get it working in the end? Normally that error seems to appear with other nodes if the item doesn’t exist or can’t be accessed.

It might be worth double checking the list name (again) and maybe trying less events to see if it is a specific event trigger causing the error.

Hey @Daniel_Barra!

To add to what Jon said, since you’re using a Trigger node, make sure your workflow is not active and you’re executing it manually while creating the workflow. Once your workflow is created and is ready, then you can switch your workflow to active.

Hi Jon and Harshil!

I just tried with all the list values available, and also with oAuth and API key.
I also removed everyone of the items except USER and SUBSCRIBE and still did not work.

I am unable to make it active, so I’m sure it is not.

Hey @Daniel_Barra,

I was able to replicate the issue. There seems to be a bug. I’ve created a ticket to get it fixed.

In the meantime, you can use the Webhook node and configure the Webhook in Mailchimp. Make sure to change the HTTP Method in the Webhook node to POST. You can configure the Test URL while building the workflow, and later replace it with the Production URL.

Hello Harshil!

Thanks for opening the ticket!

I actually have been trying with webhooks as well on a separate workflow.

This is my node:

I am executing in test mode and then trying to register the webhook on Mailchimp.

I’m getting the following error on the Mailchimp side:

When I paste the link in the browser to test the webhook, this is what I get:

Not sure how to proceed.

Hey @Daniel_Barra!

Did some quick test and found a solution. Apparently, when registering the Webhook the HTTP Method has to be GET. Once the webhook URL is saved, you then have to change the HTTP Method to POST to receive the data.

Just tested the Trigger locally and it works fine for me. @harshil1712 did you try it on cloud?

Hey @RicardoE105, I tested in on cloud. The node is working well, returning the expected result, however, the error is caused when we try to activate and save the workflow.

I’m running it on our Digital Ocean server, not using the SaaS solution.

@harshil1712 I have now done the process with GET and I was able to register on Mailchimp. But now I run in test mode to try to get test data, add a user via admin on Mailchimp and still no data arrives. I also tried editing it via admin and inserting via landing page (user insertion). Nothing arrives.

Please note that the workflow is not active currently, because I need to get at least 1 test data to build the rest of the workflow.

Below is the webhook I registered (successfully).

And the node:

Hey @Daniel_Barra,

As mentioned in my post earlier, once the Webhook gets registered, you need to change the HTTP Method to POST. After that, it should work as expected.

My bad!
I thought that was after activating the workflow.
Tested now and it worked! Thank you!!!

1 Like