Need some help in installation

I use npm to install n8n, but failed


Does this error means that I should install python? Thank you!

Hey @Kimr,

Welcome to the community :sparkling_heart:

The error message suggests that you’re using node version 16.10.0. To install and run n8n via npm the please use the LTS version of node (min. v.14.15.0)

If you still face issues please let us know :slight_smile:

1 Like

It is also saying it can’t find the Python command not sure if that is node related directly.

It might be easier to take the docker approach.

1 Like