Notion Node updating NEED HELP!

Describe the problem/error/question

Dear all,
Have somebody know howcome the Notion node updating encountered this error

What is the error message (if any)?

ERROR: Bad request - please check your parameters
length should be ≤ 2000, instead was 3885

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @ykh525050 :wave:

By that error, it looks like your content is too long for the Notion API - can you try splitting up your text and seeing if that fixes up the error? You’re almost double the limit of what their API expects :sweat_smile:

1 Like

Thank you so much!
I did found the reason and fix it.

2 Likes

but I now found another strange issue.
I set the time condition to on or before the tima stemp, but it work with 1day or 10min earlier diffent.
I’ve check the time zone setting, but still can’t figure out why.

May you kindly get me some advise?
Thank you!

Hi @ykh525050 :wave:

Could you let us know the following:

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Can you also give some example execution data of when you’re noticing this isn’t firing off at the correct time?

sorry, I am very new in n8n, there are a lot things I need to learn.

Hi @ykh525050 :wave: That’s helpful enough as it lets me know what version you’re on, and that you’re self hosting :slight_smile: But for future reference, you’d know what database you’re using as well as your EXECUTIONS_PROCESS setting in your docker-compose.yml file. AWS allows for several server types, so I’m not sure what you’re running there.

The timezone and time on your AWS server and on your n8n instance may not match - that could be the culprit here. :bowing_man:

I see, thank you for reply.
I will check the AWS site.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.