saveExecutionProgress is slow

N8N takes double to the time when i enable saveExecutionProgress.

Backend DB: Postgres
Execution mode: Queue
No of workers: 1

When i did a load test (Simulate 10 virtual users running the workflow in parallel for 1 minutes.) of a simple workflow (which calls one of N8N util nodes which generates a password), the execution takes 1.5 seconds on avg vs 2.8 seconds when saveExecutionProgress is enabled. Is there any workaround to reduce the execution time here ?

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): Main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Linux

Welcome to the community @Arun_kumar!

No, sadly not. The only thing to fix that, is to deactivate it. It being slow is expected. The larger the workflow and the larger the data, the slower it will be.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.