Scope Error using Hubspot Trigger

Glad to hear this could be sorted out :smiley:

Thanks everyone!

Hi @MutedJam - i need to work around new created contacts. Is there a way to access this endpoint : Get recently created contacts | Contacts API

If i’m not mistaking n8n provide only this one :

You’re right, n8n would fetch both updated and created contacts through the respective operation of the Hubspot node and it does not let you specify a Since date (as with the Deals).

But you could use an IF node to apply the filtering you need here. So first fetching a reasonably large number of recently created/updated contacts like so:

Then using the IF node to make sure the contact was indeed created in the last 15 minutes:

Example Workflow
1 Like

Thanks for your help as always. I’ve tested and it is working. BUT it only returns updated contact, wich are refreshed frequently by Hubspot Worflows we have in place.

It should be really easier to add the “get created” option from Hubspot API i think :slight_smile:

Hello there,

I just create a self hosted installation of n8n, and I got the same issue (version 0.160.0 installed using docker-compose)

For the scopes, I only set oauth, but nothing works (the error message say that there is insufficient domains to proceed the authentification)

I also try by adding more domains but nothing change (and has someone else said, adding too much domains / scopes can create the same problem due to conflicts)

Any ideas ?

Hi @Florian_Ruen, can you share the error full message? “insufficient domains” seems to be a different error than what has been reported in this thread so far.

Does the domain in your Redirect URL in your Hubspot applications Auth settings match the one used and shown by n8n in the credentials screen?

As for the scopes, keep in mind n8n will always request the same scopes when connecting to Hubspot. They are hard-coded here. In my tests I needed to configure these scopes for Hubspot application plus the general oauth scope to avoid any errors related to these:


Yes the Redirect URL is correctly configured to the URL n8n show me in the modal
Here is the screenshot of the error (in french)

I also try using all the scopes you mentionned in your post, and I got the exact same message and I got another message that say “My account hasn’t access to some features required by this application. Please contact the app developper”

What I’m trying to do : get most recent engagement (meeting created in Hubspot) to send Slack message to specific team.

If I can’t to do this using trigger, I will consume Hubspot API directly (more complex) to get engagement after specific date with timer (you suggest something similar earlier in this thread)

I also try using all the scopes you mentionned in your post, and I got the exact same message and I got another message that say “My account hasn’t access to some features required by this application. Please contact the app developper”

Are you by any chance using your developer account during the credentials set up in n8n?

While you’d need to set up Hubspot app using the developer account, you would need to pick your actual account during the authentication flow initiated from n8n.


It seems to work when connecting with my real Hubspot account, but when I tap on “Execute Node”, I got another strange error (maybe due to anoter update on Hubspot side ?)

Hubspot Trigger: This API can't be called using an OAuth access token. A valid developer API key must be provided in the `hapikey` query parameter, and a valid `appId` must be provided in the API request.

I double checked the credentials, api keys and appId are valid ones (this is the message returned by Hubspot API, because on my Hubspot API Dashboard, I can see the request to endpoint
/webhooks/v3/619698/subscriptions returned status code 403)

I’m looking to trigger the “Date of last meeting booked in meeting tools”, but I try using firstname and so many other properties, and I got the exact same result message.

Update :

As I seen in Hubspot Api documentation (, it seems this endpoint only accept developper api key and not oauth0 token

And in the source code of the Node, it seems the oauth token has been send in the request, maybe other encoutered same problem, or caused by recent update ?

@Florian_Ruen have you configured both your app ID and your developer API key for your Hubspot Developer API credentials in n8n? The error message suggests on or both are missing.

The developer API key is not a required field so can easily be missed. It’s not application-specific and available on the apps page of your Hubspot developer account:


Your app ID is a numeric, application specific value and available on the Auth tab of your Hubspot application in your Hubspot developer account:

1 Like

@MutedJam seems beeter, the input was filled, but using the Api key from the real Hubspot account, not the developper one !

I post here, a n8n core error (to continue on Hubspot plugin, should I continue here, or creating ne thread to classify ? I can change if needed)

NodeApiError: The resource you are requesting could not be found
    at Object.hubspotApiRequest (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Hubspot/GenericFunctions.js:40:15)
    at processTicksAndRejections (internal/process/task_queues.js:93:5)
    at async Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Hubspot/Hubspot.node.js:1962:44)
    at async /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/WorkflowExecute.js:447:47

This happend using the Hubspot Node to find engagement by ID (id returned by the trigger), the endpoint used is /engagements/v1/engagements/1643106326316 returned 404 status code, any idead ?

Having the same problem with any type of hubspot integration(trigger or not).

  1. tried developer account, new app, added all permissions, added secret/app etc - says permission denied. Screen Shot 2022-01-27 at 3...
  2. tried with developer key - same
  3. tried API key with full rights from main hubspot account(non developer) - same thing
  4. tried all the above with 2 different developer apps
  5. tried all of the above with both cloud and with desktop versions

Can someone please confirm the hubspot integration works?

Hi @filipbatelle, welcome to the community and sorry to hear you’re having trouble here.

I am not sure what exactly you mean by “the same problem” though. This thread has become a bit of a catch all for all kinds of hubspot problems.

The integration definitely works, I just used it yesterday to build a logic based on conversion dates.

When using you could avoid moist of the struggle by using the regular Hubspot node with OAuth2 authentication:

In that case no developer apps would need to be configured in Hubspot and the authentication process can be initiated with a single click:

Make sure to update your cloud instance to a recent version of n8n (≥ 0.157.0) beforehand to include the latest changes to the Hubspot node.

Thanks for the reply @MutedJam

Ok so I updated to latest version

Then I create a new hubspot trigger node and create new credentials on n8n.
On Hubpsot, created an app specifically for this case. I copy values from hubspot developer app into the n8n hubspot credentials. See permissions below:

Then in n8n I click connect and get this popup

Regardless of which option I choose(developer or actual hubspot account) it shows the permission errors
Developer option

Hubspot business account option

It sounds like I’m missing something very obvious. Can it be my hubspot account? or maybe you have different permissions than I do?

I have the same issue with “Hubspot Trigger node”, i’ve connected my developer app and still having an error while executing the node :

I need your help guys, thank you

Hi @Mahdi, welcome to the community!

I’ve had a call with @filipbatelle the other week during which we looked at Hubspot in a bit more detail.

Here are some observations from this:

  1. Hubspot does not allow all developer accounts yet to set the below scopes required by n8n, so you might need to create a fresh developer account to avail of Hubspot’s latest functionality here.
  2. When using the Hubspot Trigger node, the scopes configured for your Hubspot developer application need to be exactly these (no additional scopes):
    • oauth
  3. The Hubspot Trigger credentials require your developer account’s API key (which is different from a regular Hubpot account API key). It’s available through the apps page in your Hubspot developer account:

Hope this provides some pointers for you and others stumbling across this thread.

Yeah it works now ! Thank’s

1 Like

Any one can help me out to connect my hubspot account with n8n local.

Hey @Raj_Rathod,

Welcome to the community :tada:

Which bit do you need help with? What version of n8n are you using, What error are you seeing, Did you follow the steps in our documentation or in this thread?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.