The Telegram trigger isn't triggered

Describe the problem/error/question

Hi everyone,

Apologies if it was already answered :slight_smile:
Has anyone seen this issue? I’ve already configured a Telegram trigger, but the Telegram trigger isn’t triggered for some reason. Everything is behind the CloudFlare Zero Trust tunnel :slight_smile:

What is the error message (if any)?

I click Listen For Event, but nothing happens :slight_smile:

Please share your workflow

Information on your n8n setup

  • n8n version: Docker image: n8nio/n8n:latest
  • Database (default: SQLite): not using via docker-compose
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu 22.04

that happened to me too when I used the same api key in a different workflow. Try to stick to one api key per trigger - if not sure, you can reset the api-key, most of the time it works.

1 Like

Ohh, thank mate. I’ll try this approach then :slight_smile:

Same hehe :))

did it work?

1 Like

Thanks for asking. Nope, same behaviour hehe :slight_smile:

It might be worth checking that your telegram bot is using the correct url, we will typically send the value of the webhook_url so this would need to match your cloudflare tunnel url. There is also a limit with telegram where you can only have one webhook for each bot.

1 Like

Sorry for askin, mate. How would you test it via Postman or curl?)

Also, most of the time it crashes on a white screen with a few errors :slight_smile:

Unchecked runtime.lastError: The message port closed before a response was received.
ParameterInputList-d39ea23a.js:53 Uncaught SyntaxError: Invalid or unexpected token (at ParameterInputList-d39ea23a.js:53:9682)

Running on a newly created DO droplet and finding the same behaviour :slight_smile:

Works fine on instance :slight_smile:

Testing with the Caddy container which was commented out earlier in compose file and n8n was behind the CF tunnel. It is now proxied to the DO droplet via A write to CF. However, encountered another error:

## Problem running workflow

*Bad request - please check your parameters*

Show Details

Telegram Trigger: Bad Request: bad webhook: IPv6-only addresses are not allowed

UPD: The error has disappeared on its own lol

It seems to be working now. The error has disappeared on its own lol


Well this was a bit of an exciting topic to catch up on :joy: glad you have it sorted though.

1 Like

Ahah :joy: Yeah, thanks so much Jon :upside_down_face:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.