Using baserow node

Describe the issue/error/question

Hi, first thank’s for the very nice work you’ve down with n8n. Really a interesting tool for my first steps in automation.

I have trouble using the baserow node in n8n. I have created the api token. Created a credential in n8n. Collected the base Id and table Id, but in every test I’ve done (get and write) I have this error message :

What is the error message (if any)?

ERROR: Bad request -please check your parameters
request failed with status code 400

Information on your n8n setup

  • n8n version: Desktop app on windows 10
  • Database you’re using (default: SQLite):

I’m pretty sure I’ve done something wrong but I couldn’t found my error(s). And I didn’t found an answer for my problem in the documentation or the community.

When I use the same API token with a curl or requests (python), the token is working.

Is it possible to have a clear example for the setting of the credential (the credential has a username and password , and I have just an API token from baserow) ? Or/and a example of a operational node ?

thanks for your help.

Michel

Hey @Michel,

I had a similar experience the other day when using it, It turns out we don’t currently use the API tokens with Baserow so you would need to input your username and password that you use to access Baserow rather than the API token option.

Hey @jon,

Thanks for your fast answer and good to know for the API token.

I’ve tested my username & password too but … same result.

The database and Table fields are with a red flag (Issues: there was a problem loading the parameter options from server: “bad request -please check your parameters”)

I could write a db and table id of course but same error when executing the node (request failed with status code 400)

Hey @Michel,

That is a bit odd, Next to the exclamation mark there are some cogs if you hit that and do refresh list does it start working?

Are you using Baserow cloud or self hosted as well?

Nope for working after refresh list.

Baserow cloud hosting in my case.

screenshot = I have red flags (I’ve suppressed here the db and table ids for the screenshot ) when I open/use the node.

And I have checked my username/password for the credential of course.

It’s perhaps linked to the use of baserow cloud in my case don’t you think ?

Anyway, I will use another db in the meantime to test my worflows.

Thanks for your help @jon !

Hey @Michel,

Oddly enough I did a quick test using cloud and it worked that was what led me to ask as it could have been a local issue.

I do get the same icons but for me I have the dropdown for Database :thinking: @MutedJam any thoughts?

Cool if your test is working!

So it’s probably a local issue or a “local brain problem” :wink:

Will do some test later from scratch

1 Like

As it is just for science and only a test instance I made I can DM you the username and credentials for the test instance I just made.

I am going to kill it once this is solved anyway :smile:

2 Likes

Would be wonderful @jon !

Should be in your DM box now @Michel

Thanks @jon !

I’ve tested your credentials. Same results.

So I’m somewhere happy it’s not a brain issue :slight_smile: .

You are right must be a local issue

Just to be clear = I could not select a database or more precisely when I click on select , I have nothing

I will start from scratch a Db on baserow and a new workflow to do a new trial tomorrow

@jon from scratch yours credentials works . Mine nope. So probably something wrong when we created the db on baserow .

Don’t forget to delete them !

Big thanks for your help !!!

No problem, If you work it out it would be good to know. I know with my test credentials I made a second database and it sort of just worked after I clicked the refresh button.

1 Like

I’ve just created a baserow with my personal account. And the baserow node works without troubles.

I don’t understand why the other account doesn’t work…

But not related to n8n ! (couldn’t use your credential the first time because i’ve forgotten to refresh … So finally it’s a brain issue :slight_smile: mine need rest lol)

Thanks one more time for your help and the DM for my testing.

Sorry for the inconvenience !

2 Likes

@jon

Just a few words to say that I’m really impressed by n8n.

Minus our internal hiccup with baserow, I’ve have reproduced the biggest part of a pipeline (+200 API request >ML with notebook and papermill) in n8n in a few hours !

And I’m not a dev.

n8n rocks !

Bravo to the Team !

5 Likes

@Michel that is great news, if you are up for it I am sure our head of product @sirdavidoff would love to have a chat with you to find out more about how you are using n8n and what you struggled with / what you liked to help us better shape the future development plan :slightly_smiling_face:

1 Like

With pleasure after our tests so I’ve a better understanding of our struggles and positive points.

At this stage we testing a lot of ideas and as javascript is like digital hieroglyphs for me :wink: … The chat will not be very useful for him.

1 Like

Thanks @jon, I’ve just messaged Michel to see if he might be up ofr a chat :slight_smile:

1 Like

Hi @jon ,
Wondering if there will be an update to the Baserow credentials to support API tokens instead of credentials. These are much more secure as they can be limited in scope easily, deleted and created at the admin’s will, and the user doesn’t have to share their main credentials.
Thanks!
Tomer