Webhook output: name of binary data changes from 00 to 0

Describe the problem/error/question

I send ONE file (image) to a n8n webhook:
some days before, this file got the binary data name “00” in the output of the webhook
today its name is “0”
In this case the following nodes won’t match to the expected name “00”
What is the reason for this change? how can i set a constant name?

What is the error message (if any)?

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.11.2
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): cloudron/Docker
  • Operating system:

Hey @RoP,

The issue with 00 I think we solved recently, Did you n8n instance update recently or is Cloudron set to automatically update when we update the latest branch?

1 Like

Hi @Jon ,
thanks for your fast reply!
Yes, Cloudron is set to automatically update. (1.11.2)
as shown here: Release notes | n8n Docs
Releases · n8n-io/n8n · GitHub
1.11.2 is version latest and cloudron only updates to version latest (on github).

In which version this sissue is solved and when do you set this version (or higher) to latest?

1 Like

The additional 0 was most likely caused by a bug accidentally introduced in 1.2.0, until it was reported couple of weeks ago.
so, we reverted that behavior to stay backward-compatible in version 1.11.0.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.