WooCommerce Trigger Stopped Working

Describe the issue/error/question

My WooCommerce Triggers for New Orders and Order Update stopped working yesterday. Seems it happened right after the WooCommerce update to version 7.5.0. Anybody has an idea of the cause and how to resolve that?

Information on your n8n setup

  • n8n version: 0.217.1
  • Database you’re using (default: SQLite): Postgre
  • Running n8n with the execution process [own(default), main]: queue
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Hey @Martin_Neumann,

Does WooCommerce log anything for the connection? It sounds like if an update to WooCommerce has stopped it then something may have changed in WooCommerce I would check the settings to see if anything is different.

I looked at the Webhooks delivery log and it showed the logs that have arrived on n8n. What other logs can I look at?

Hey @Martin_Neumann,

On the n8n side we have the execution log which would need to be enabled if it isn’t already that will show any webhook call that has come in if it is has failed or worked. If something is not there it would maybe point to something either in WooCommerce not working as expected or something between them.

So the next step would be to check the WooCommerce logs and if that all adds up then everything is good but if the WooCommerce log doesn’t have any records then it would be a question for the WooCommerce Team, If you have data in WooCommerce but nothing in the n8n side I would check between them so if you have a reverse proxy in front of n8n you can check the logs for that to see if the request ever makes it.

Yes like I said the Woocommerce webhook delivery log was not showing any webhooks fired, so I guess I need to get into the Woocommerce support forums about that.

1 Like

Hey @Martin_Neumann,

You got it, I thought you were checking the n8n log. If you wanted to try troubleshooting further I would maybe check the WooCommerce server logs if it has any it could just be that the internal schedule has stopped working.

Have you tried restarting the woocommerce server to see if that kicks it a bit?

We currently have similar issues. I get a “Couldn’t connect with these settings More details” on the woocommerce trigger.

I can connect to the rest api using postman with the exact same credentials, though. So perhaps the Woocomm update changed some endpoint or something?

Hey @Jelle_de_Rijke,

That could be it, Although if the webhook is created the endpoint on WooCommerce shouldn’t matter as it should be posting the data still.

I don’t know exactly how the Woocommerce trigger is built, but I did notice that it works slightly different from the regular Woocommerce webhooks. A regular Woocomm webhook call provides a lot less fields with the initial webhook call, compared to the woocommerce trigger node.

So not really sure how to debug this issue, since the woocommerce node does not seem to be using the standard woocommerce webhooks system. I could be totally wrong, but maybe you know more about this @Jon?

Hey @Jelle_de_Rijke,

From what I understand we use the standard v3 api to create a webhook, I am not sure why that wouldn’t look like others though.

I am also not sure what error you are seeing but a screenshot would be helpful so I can see the full error and what options you are using.

Hey @Jon,

Here are the screenshots of the problem @Jelle_de_Rijke previously mentioned.


1 Like

Hey @corne_Whoon,

Welcome to the community :cake:

Perfect so that output is very different from what I was expecting, What happens if you toggle the Include Credentials in query option?

I have just given this a test on a 7.5 install and I can see the webhooks are created, I have used the Include Credentials in Query option.

The triggered events are also coming through without issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.