Your workspace is running an outdated version

Hi I got the email reminding me, that I am running an outdated version (hosted version)
I run 1.3.1 when I want to update I get this versions to choose from:

So I need to downgrade?

Thank you

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

We use semantic versioning. So the different numbers between the points have different meanings. It is:
<major>.<minor>.<patch>
It is read from left to right, the most important number on the left.

So, in your case, the major version is the same. But your minor version is 3 and the one we have set as stable is 29. That means you are currently around 26 minor versions behind. As we normally release a new minor version every week, that means the version you currently use is roughly 26 weeks old (actually a little bit more as we already released 30 and will release 31 today). I hope that helps.

2 Likes

That helps thank you

You are welcome. Have fun!

To update your n8n workspace:

  1. Access your server.
  2. Run the update command appropriate for your installation method.
  3. Verify the update.
  4. Restart services if needed.
  5. Test functionality.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.