Zendesk trigger nodes : cannot activate workflow


I have difficulties with a workflow that use multiple Zendesk Trigger nodes.
Even tough it works when executing the workflow manually, I can’t activate the workflow.

I receive the following message :

“There was a problem and the workflow could not be activated:
Bad request - please check your parameters
Show Details
Pending ticket: 400 - undefined

“Pending ticket” is the name of one of the zendesk trigger nodes, that starts the flow when a zendesk ticked is pending. But sometimes the message change, after trying to activate the workflow several time : I had the same 400 error with the “New ticket” zendesk trigger node instead of the “Pending ticket” node.

Below is my workflow, could you help me with this please ?

Thanks in advance :pray:
Flow below

Hi @bkaplan, I hope you are having a good day thus far?

First of all let me say sorry for the inconvenience this causes. I quickly copied your workflow and did not run into any problems when activating the workflow on my own Zendesk instance. Would you be able to share the full error you are seeing (if there are any more details)?

Also, we have released a bunch of changes recently affecting the Zendesk node. Would you be able to confirm whether the problem still persists when using the recent 0.144.0 release of n8n?

If the above doesn’t help, it might be worth reaching out to Zendesk’s support team as a 400 response suggests the server (in this case the Zendesk API) didn’t like the request we were sending to them. So they should be able to provide additional details on what exactly was wrong here.

Don’t know if it helps but 141 and 142 are both working with trigger nodes.

Hi @MutedJam, I am good thanks, how are you ?

I actually shared the full error message (no more details available) and despite the recent release the problem remains : I cannot activate the workflow (even though executing it manually does work).

I just realized that the successive merges might be part of the reason : when working with only one trigger node, i can activate the workflow without problem.

So I should have a workaround solution (create 5 simples flows instead of a complex one) but now i have a new problem : even though my workflow is activated and I have no error message of any kind, the flow does not work.
To be more precise : When I do the exact action that trigger the workflow successfully in manual mode, the is no execution when the flow is active. No execution, no error message, i look at my history and nothing appears.

Did I forget something in the activation process ?

here is the simplified flow :

Hi @Jon , what do you mean ?

I meant that I tested with 2 different versions of n8n and Zendesk Trigger nodes seemed to activate and work without issue.

I did update to 144 to use the new Zendesk node features and the triggers still appear to be working. Out of interest have you tried using the Token option instead of OAuth? There was a change that broke some of the oauth processes so it could just be that you are seeing that.

Have you tried adding N8N_USE_DEPRECATED_REQUEST_LIB=true to your environment options to see if that helps?

By any chance, does your callback URL says localhost?