Typeform trigger doesn't receive any filled form

Hi guys,

I’ve setup a self hosted n8n.io with docker and it works like a charm on my subdomain https://yy.xxxx.com
I’m trying to make a Typeform trigger which send the information into Odoo opportunity.

Describe the issue/error/question

The problem is than I can’t figure out why I’m not getting any response from Typeform when executing the workflow even if I fill the form.
I tried with both authentication (Developper apps & personal tokens), it’s change nothing.

When I listen for event, I’m always getting : Waiting to execute…

Any idea/suggestion of why it’s not working ? I didn’t find any help with other topics… checked everythings.

Thanks in advance!

What is the error message (if any)?

I didn’t have any error message, so it’s hard for me to understand what’s wrong.

Please share the workflow

Share the output returned by the last node

That’s what I’m trying to get.

Information on your n8n setup

  • n8n version: latest v0.182.0
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: I’m sorry, I don’t understand
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: docker

Ok, atfer investigating more, I got the error. I didn’t saw than typeform as a webhook panel with the response of the n8n request.
I got a 503 error because of cloudflare security, so I found a workaround (WAF rules).
And now, no more error

1 Like

Hi @Locos

Welcome to the community.
You are asking a few questions, and I am not sure where to start and what questions you haven’t fixed yet.
To Start I will explain the trigger node “waiting to execute”.
Triggers nodes have 2 webhook URLs, a test url and a production url. When you press execute in the designer/ workflow editor. It will wait for data to be sent to the test url. This so you can test out the flow without setting it live and so you can use the data in the development of the workflow.
The production url is used when the workflow is set to be active. Then it will wait for that url to receive date and execute the workflow in the background. It will not show in the designer, but will be visible in the execution list.

For the other questions I am not sure what you have managed to fix and what the actual question is.


Yes, I got it. The only thing missed in the documentation is than we can have a view to the response of the webhook directly from Typeform admin dashboard (Connect tab then Webhook).
That’s how I find and understand why it was not working.

Everything is fine now!