Webhook Trigger Node couldn't receive POST resquest

Describe the issue/error/question

I tried to send a webhook from my app to Webhook Trigger Node and it normally works. It is a POST request. But now Webhook node couldn’t collect my POST request and is just loading until timeout.

Before anyone asks, yes I checked the Test URL, I run it in tunnel mode, I did check it with https://hookbin.com/ and hookbin sure received it.

Hey @dati18,

Welcome to the community :birthday:

Are you using the webhook test url or the normally webhook url?

When you send from your app does it show as a success? It could be worth trying something like curl to the webhook to see if that triggers it as well. How do you have n8n installed as well is it docker, npm or desktop? I noticed you mentioned tunnel as well it could be worth restarting the instance and checking the tunnel url to make sure it has not changed.

Hi @jon, thanks for answering.
I used the webhook test url of course. I did curl to the webhook (locally) and somehow it works?? But when I send it from my app it doesn’t trigger the Node. But if I send it from the app to n8n.cloud or hookbin it does work like a champ. but somehow my localhost n8n refused to catch the http request.
I installed n8n using npm, the tunnel url is fine, at this point I’m frustrated and I don’t understand what causes it anymore…

Hey @dati18,

It sounds like if it is working locally but not from the app it could be network related although using the tunnel should remove some of those issues :thinking:

Have you checked the app that is sending the request to see if it is reporting any errors or timing out?

I found out what happened, and it’s related to verifying the peer’s SSL certificate. Everything’s cool now :smiley:

2 Likes