Webhook without data

Hi, I’m a user with basic knowledge, but I managed to install N8N on my server but I’m having problems with Webhook.

I did the installation by docker in ubuntu 20.04 following the guidelines of the documents Server Setup | Docs

Access via my domain no problem, but Webhook via POST does not receive the data.

I did a test starting with --tunnel

docker run -it --rm \
	--name n8n \
	-p 5678:5678 \
	-v ~/.n8n:/home/node/.n8n \
	n8nio/n8n \
	n8n start --tunnel

and the webhook worked normally.
but I can’t get it to work other than through --tunnel.
Neither by test url nor by production, always returned “No data”
Do you have any settings I need to do or anything I might have set wrong?

I greatly appreciate your help

Hey @Rodrigo_Barbosa,

Does it just say no data or is there more to it? Which environment variables did you set and are you using the test webhook or production one?


I reinstalled from scratch and it worked, I believe I made a mistake during the installation. Thank you very much